35 lines
957 B
Nix
35 lines
957 B
Nix
{ pkgs, lib, config, ... }:
|
|
{
|
|
nixpkgs.overlays = [
|
|
(self: super:
|
|
(let
|
|
patched = import ../../packages/patched-derivations.nix super;
|
|
in {
|
|
|
|
inherit (patched)
|
|
ddcci-driver-with-global-control
|
|
kubo
|
|
nerdfonts-terminus
|
|
terminus_font_fancy
|
|
libfprint
|
|
fprintd
|
|
;
|
|
|
|
doas = patched.doas-interactive;
|
|
|
|
hydra-unstable = patched.hydra;
|
|
|
|
nix-direnv = super.nix-direnv.override {
|
|
nix = config.nix.package;
|
|
};
|
|
|
|
} // lib.optionalAttrs config.services.xserver.desktopManager.gnome.enable {
|
|
|
|
ungoogled-chromium = super.ungoogled-chromium.override {
|
|
commandLineArgs = "--enable-features=OverlayScrollbar,OverlayScrollbarFlashAfterAnyScrollUpdate,OverlayScrollbarFlashWhenMouseEnter --auth-server-whitelist=*privatevoid.net";
|
|
};
|
|
|
|
inherit (patched) gnome-control-center nautilus;
|
|
}))
|
|
];
|
|
}
|