mirror of
https://github.com/privatevoid-net/nix-super.git
synced 2024-11-15 18:56:16 +02:00
08b59aad31
Co-Authored-By: Qyriad <qyriad@qyriad.me> Co-Authored-By: Robert Hensing <robert@roberthensing.nl> Co-Authored-By: eldritch horrors <pennae@lix.systems> Co-authored-by: Jörg Thalheim <Mic92@users.noreply.github.com> Co-authored-by: Tom Bereknyei <tomberek@gmail.com>
24 lines
634 B
Meson
24 lines
634 B
Meson
rl_next_generated = custom_target(
|
|
command : [
|
|
'bash',
|
|
'-euo',
|
|
'pipefail',
|
|
'-c',
|
|
'''
|
|
if type -p build-release-notes > /dev/null; then
|
|
build-release-notes --change-authors @CURRENT_SOURCE_DIR@/../../change-authors.yml @CURRENT_SOURCE_DIR@/../../rl-next
|
|
elif type -p changelog-d > /dev/null; then
|
|
changelog-d @CURRENT_SOURCE_DIR@/../../rl-next
|
|
fi
|
|
@0@ @INPUT0@ @CURRENT_SOURCE_DIR@/../../rl-next > @DEPFILE@
|
|
'''.format(
|
|
python.full_path(),
|
|
),
|
|
],
|
|
input : [
|
|
generate_manual_deps,
|
|
],
|
|
output : 'rl-next.md',
|
|
capture : true,
|
|
depfile : 'rl-next.d',
|
|
)
|