depot/hosts/options/hour/hardware.nix

19 lines
236 B
Nix

{ lib, ... }:
with lib;
{
options.hardware = {
cpu = {
cores = mkOption {
type = types.ints.unsigned;
};
};
memory = {
gb = mkOption {
type = types.ints.unsigned;
};
};
};
}