depot/modules/nix-register-flakes/default.nix
2023-03-11 19:48:30 +01:00

21 lines
404 B
Nix

{ depot, ... }:
with depot.inputs;
{
nix.nixPath = [
"repl=/etc/nixos/flake-channels/system/repl.nix"
"nixpkgs=/etc/nixos/flake-channels/nixpkgs"
];
nix.registry = {
system.flake = depot;
nixpkgs.flake = nixpkgs;
default.flake = nixpkgs;
};
environment.etc = {
"nixos/flake-channels/system".source = depot;
"nixos/flake-channels/nixpkgs".source = nixpkgs;
};
}