depot/packages/shadows.nix
2024-08-02 12:42:26 +02:00

16 lines
447 B
Nix

{ lib, ... }:
{
perSystem = { inputs', self', ... }: {
# much like overlays, shadows can *shadow* packages in nixpkgs
# unlike overlays, shadows don't cause a nixpkgs re-evaluation
# this is a hack for dealing with poorly written NixOS modules
# that don't provide a `package` option to perform overrides
options.shadows = lib.mkOption {
type = with lib.types; lazyAttrsOf package;
default = { };
};
};
}